Siklu EtherHaul Unauthenticated Remote Command Execution Vulnerability (<7.4.0)

fulldisclosure logo
Full Disclosure
mailing list archives

Siklu EtherHaul Unauthenticated Remote Command Execution Vulnerability (<7.4.0)


From: Ian Ling <iancling () gmail com>

Date: Mon, 20 Feb 2017 12:30:36 -0800


[+] Credits: Ian Ling
[+] Website: iancaling.com
[+] Source: http://blog.iancaling.com/post/155127766533

Vendor:
=================
https://www.siklu.com/

Product:
======================
-Siklu EtherHaul (EH-*)

Vulnerability Details:
=====================

Siklu EtherHaul devices are vulnerable to an unauthenticated remote command
execution (RCE) vulnerability. This vulnerability allows an attacker to
execute commands and retrieve information such as usernames and plaintext
passwords from the device with no authentication.

Affected versions:
<7.4.0

Impact:
The remote attacker has full admin access to the device.


Disclosure Timeline:
===================================
Vendor Notification: December 22, 2016
Initial Response: December 22, 2016
Patched by Vendor: February 13th, 2017
Public Disclosure: February 20th, 2017

Exploitation Technique:
=======================
Remote, no authentication required

Severity Level:
================
Critical

_______________________________________________
Sent through the Full Disclosure mailing list
https://nmap.org/mailman/listinfo/fulldisclosure
Web Archives & RSS: http://seclists.org/fulldisclosure/


  By Date  
     
  By Thread  

Current thread:

  • Siklu EtherHaul Unauthenticated Remote Command Execution Vulnerability (<7.4.0) Ian Ling (Feb 21)

Source: Full Disclosure @ February 21, 2017 at 01:19PM

0
Share