Flaws Found in Emerson DeltaV, Liebert Products (SecurityWeek)

ICS-CERT has published three advisories describing vulnerabilities discovered in Emerson’s DeltaV and Liebert products by the company and outside researchers.

The most serious of the flaws, rated “high severity” with a CVSS score of 7.5, was identified by Evgeny Ermakov from Positive Technologies.

The expert noticed that Emerson’s Liebert SiteScan tool, which allows organizations to control and monitor critical support equipment, is affected by an XML external entity (XXE) vulnerability that can be exploited to execute arbitrary code or access files from a server or a connected network.

The flaw, tracked as CVE-2016-8348, is caused by a poorly configured XML parser. The weakness can be exploited remotely even by an attacker with low skill, ICS-CERT said.

The issue affects SiteScan 6.5 and prior. Patches can be obtained from the vendor by calling Liebert Services at 1-800-543-2378.

Emerson discovered a couple of flaws related to its DeltaV distributed control system. According to ICS-CERT, the DeltaV Wireless I/O cards, which connect workstations and servers in the DeltaV network, have SSH functionality enabled. This functionality is not necessary and it introduces a security risk. A hotfix released by Emerson disables the SSH port on the affected product.

Another vulnerability affects the DeltaV Easy Security Management app, which is used for managing portable media ports and the autorun feature on servers and workstations. The application has a flaw that could be exploited to elevate privileges on the control system.

While this could be a serious issue, ICS-CERT pointed out that the security hole can only be exploited by a local attacker and crafting an exploit is not easy.

Emerson is not releasing fixes for this vulnerability as the product is no longer supported. Users have been advised to uninstall the application from all workstations and servers.

“Emerson will provide additional details explaining how to manage USB ports and autorun features using Windows Group Policies in the near future as part of another Knowledge Base Article to be published through Emerson’s Guardian Support Knowledge Base,” ICS-CERT said.

Related: Library Flaw Could Crash HART-Based ICS Field Devices

Related: Emerson Patches SQL Injection Vulnerability in ICS Product

Previous Columns by Eduard Kovacs:

Tags:

Source: SANS ISC SecNewsFeed @ November 30, 2016 at 07:27AM

0
Share